笔记

node-sass 依赖安装失败

2019.01.29 14:34
NPM

今天准备构建 Taro 项目,taro init 之后安装依赖一直加载,最后出现 error \node-sass: Command failed错误。

判断应该是 node-sass 被 Q ,导致网络请求超时;搜过之后,记录一个修复方案。

  1. node -p "[process.platform, process.arch, process.versions.modules].join('-')" 查看本地机器的版本。(我的本地是win32-x64-57)
  2. https://github.com/sass/node-sass/releases 下载对应的版本文件。(我的是下载win32-x64-57_binding.node)
  3. 设置 Sass 路径 set SASS_BINARY_PATH=D:/nodejs/.nodes/win32-x64-57_binding.node,地址以本地为准。
  4. 安装 node-sass 模块:npm i node-sass -D --verbose
  5. 然后在项目的根目录下:npm install 即可。

参考 https://www.cnblogs.com/ignacio/p/6911864.html

快发表第一个评论吧 ~